Typecho 0.9版的代码高亮插件 -- Highlight JS

插件开发及发布

版主: woniou

Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子joyqi » 2013年 12月 6日 15:24

由于Typecho的新版本更新了一些插件接口,导致以前的很多代码高亮插件都用不了。于是我结合最强大的Highlight JS高亮库,制作了这个Typecho插件,该插件只能使用在Typecho 0.9第二个beta版及以后的版本中。它有如下的特色

完全前台渲染,不占用后端资源

由于使用了Highlight JS来渲染代码高亮,所以所有的动作都在浏览器端完成,不会占用任何后端计算资源。

兼容以前的代码格式

在插件设置中打开兼容模式,即可支持以前没有用Markdown书写的代码高亮。如果你的blog已经全部是Markdown书写,建议你不要打开它以节省资源。

30余种代码高亮样式任你选择

QQ截图20131206151544.png
QQ截图20131206151544.png (24.26 KiB) 被浏览 10518 次


放个效果图

QQ截图20131206152330.png
QQ截图20131206152330.png (66.33 KiB) 被浏览 10518 次


下载链接

http://70.io/develop/highlight-js-typecho-plugin.html
头像
joyqi
 
帖子: 420
注册: 2007年 7月 24日 19:43

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子wwwdsd » 2013年 12月 6日 16:57

:lol: 围观70,支持了
wwwdsd
 
帖子: 261
注册: 2009年 6月 13日 23:06

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子mybg » 2013年 12月 6日 17:32

不启用兼容模式 的话,一直要求

必须选择一个模式
mybg
 
帖子: 508
注册: 2010年 5月 27日 16:20

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子ShingChi » 2013年 12月 6日 20:50

:D 前两天还想把 highlight.js 插件搞出来,70 竟然整了,地板围观
头像
ShingChi
 
帖子: 910
注册: 2010年 6月 16日 10:11

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子joyqi » 2013年 12月 6日 21:05

mybg 写道:不启用兼容模式 的话,一直要求

必须选择一个模式


去下载新版本,我修正了这个bug
头像
joyqi
 
帖子: 420
注册: 2007年 7月 24日 19:43

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子mybg » 2013年 12月 6日 21:28

joyqi 写道:
mybg 写道:不启用兼容模式 的话,一直要求

必须选择一个模式


去下载新版本,我修正了这个bug


收到!已升级新版,正常。

但评论里的代码会被吃掉,以前都能正常显示的。
viewtopic.php?f=4&t=4468
mybg
 
帖子: 508
注册: 2010年 5月 27日 16:20

Re: Typecho 0.9版的代码高亮插件 -- Highlight JS

帖子lepig » 2013年 12月 20日 19:30

joyqi 写道:
mybg 写道:不启用兼容模式 的话,一直要求

必须选择一个模式


去下载新版本,我修正了这个bug


怎么用啊。新手求教
头像
lepig
 
帖子: 5
注册: 2012年 9月 17日 16:09


回到 插件及扩展

在线用户

正在浏览此版面的用户:Bing [Bot], Google [Bot] 和 7 位游客