安装时报Database Server Error

解决您在不同平台环境下遇到的安装和升级问题

安装时报Database Server Error

帖子TheInterestingSoul » 2019年 8月 19日 18:46

安装时适配器选择myspl原生,自动重载后就老是提示Database Server Error
版本是php7.2
TheInterestingSoul
 
帖子: 1
注册: 2019年 8月 19日 12:50

Re: 安装时报Database Server Error

帖子jefsky » 2019年 8月 23日 16:30

Typecho不支持PHP7.0,需要将数据库引擎修改成Pdo_Mysql(修改根目录下的config.inc.php)

代码: 全选
/** 定义数据库参数 */
$db = new Typecho_Db('Pdo_Mysql', '*********');
$db->addServer(array (
  'host' => '*******',
  'user' => '*******',
  'password' => '*********',
  'charset' => 'utf8',
  'port' => '3306',
  'database' => '**********',
  'engine' => 'MyISAM',
), Typecho_Db::READ | Typecho_Db::WRITE);
Typecho_Db::set($db);


--------------------------------------------
By 程序猿Jefsky 来自 程序猿甜品店 希望可以帮到你
头像
jefsky
 
帖子: 19
注册: 2019年 7月 3日 11:29

Re: 安装时报Database Server Error

帖子lison » 2019年 8月 29日 18:38

同样的问题,php版本是5.6
lison
 
帖子: 4
注册: 2019年 8月 29日 18:30

Re: 安装时报Database Server Error

帖子lison » 2019年 8月 29日 18:49

在阿里云上安装出现的这个问题,但是在另一家云主机(php版本7.2.5)却安装成功
lison
 
帖子: 4
注册: 2019年 8月 29日 18:30


回到 安装和升级问题

在线用户

正在浏览此版面的用户:没有注册用户 和 2 位游客