0.9新版本使用问题汇集

讨论程序使用中的问题

0.9新版本使用问题汇集

帖子ShingChi » 2013年 12月 17日 12:48

我个人主张先搜索(我发现论坛的搜索功能超差劲,到目前为止关键词搜索没成功一次过),其次再提问,不然,即使人家会,都懒得重复回答一个问题十几次。还有,可以先看论坛、文档有没有相同问题或解决方法,再者,可以关注下 typecho 在 github 的 issues : https://github.com/typecho/typecho/issu ... ate=closed

还有其他问题的话,大家可以一起添加搜集。

一、编辑器问题

1. 旧文章为什么不能加载 markdown 编辑器?
因为要对旧文章做兼容处理,默认旧文章是不使用markdown编辑器的,不管你旧文章是否用markdown格式还是其它格式输入的,都无法启用编辑器,如果你需要让旧文章支持新版的markdown编辑,需要用转换插件或者批量更改数据库内容。
冰剑的批量转换旧文章格式插件:http://forum.typecho.org/viewtopic.php?f=6&t=4257
如果旧文章也是markdown格式,可以尝试这个:http://d.lcz.me/48.html


2. 为什么新版markdown编辑器不支持某些标签?
因为考虑的安全问题,程序默认就做了某些标签的过滤,所以一些特殊的标签已经过滤点,如果你实在想打开,可以更改源文件。
修改参考:https://github.com/typecho/typecho/blob/master/var/MarkdownExtraExtended.php#L148


3. 我不想使用 markdown 编辑器,想用以前的怎么办?
这个问题,我只能说你马虎粗心,后台个人设置里,明明有关闭 markdown 编辑器的按钮。
如果你非得折腾要用插件,可以使用公子开发的几个插件。
http://forum.typecho.org/search.php?keywords=&terms=all&author=lizheming&fid%5B%5D=6&sc=1&sf=titleonly&sr=topics&sk=t&sd=d&st=0&ch=300&t=0&submit=%E6%90%9C%E7%B4%A2


二、云环境问题

1. BAE 安装 403 错误及无法进后台?
在安装前,你需要配置下规则才行,你可以在根目录传个app.conf,里面写上以下代码
代码: 全选
handlers:
  - url : /
    script: index.php

  - expire : .jpg modify 10 years
  - expire : .swf modify 10 years
  - expire : .png modify 10 years
  - expire : .gif modify 10 years
  - expire : .JPG modify 10 years
  - expire : .ico modify 10 years
  - url : /(.*).php
    script : /$1.php

安装成功后,如果你在后台启用了永久链接,启用后可以把app.conf内容更改为以下代码
代码: 全选
handlers:
  - expire : .jpg modify 10 years
  - expire : .swf modify 10 years
  - expire : .png modify 10 years
  - expire : .gif modify 10 years
  - expire : .JPG modify 10 years
  - expire : .ico modify 10 years
  - url : (.*)\.css$
    script : $1.css
  - url : (.*)\.js$
    script : $1.js
  - url : (.*)\.jpg$
    script : $1.jpg
  - url : (.*)\.gif$
    script : $1.gif
  - url : (.*)\.png$
    script : $1.png
  - url : (.*)\.jpeg$
    script : $1.jpeg
  - url : (.*)\.ico$
    script : $1.ico
  - url : (.*)\.swf$
    script : $1.swf
  - url : /admin(/?)$
    script : /admin/index.php
  - url : /admin/(.*)\.php$
    script : /admin/$1.php
  - url : (.*)
    script : /index.php


三、其他问题

1. 自定义字段如何使用?
首先,你得在写文章的时候输入创建一个自定义字段,然后在模板里像以下这样输出该字段。
代码: 全选
<?php if (isset($this->fields->fieldName)): ?><?php $this->fields->fieldName(); ?><?php endif; ?>
最后由 ShingChi 编辑于 2013年 12月 17日 22:53,总共编辑了 5 次
头像
ShingChi
 
帖子: 910
注册: 2010年 6月 16日 10:11

Re: 0.9新版本使用问题汇集

帖子muchun » 2013年 12月 17日 13:00

写到文档吧
头像
muchun
 
帖子: 734
注册: 2011年 11月 24日 10:39

Re: 0.9新版本使用问题汇集

帖子ShingChi » 2013年 12月 17日 13:05

muchun 写道:写到文档吧

无力吐槽文档,改版前有权限,但是权限限制问题,输出都是乱码。改版后,没权限修改文档。
头像
ShingChi
 
帖子: 910
注册: 2010年 6月 16日 10:11

Re: 0.9新版本使用问题汇集

帖子wwwdsd » 2013年 12月 17日 23:28

顶顶更健康,送上肥皂一块
wwwdsd
 
帖子: 261
注册: 2009年 6月 13日 23:06

Re: 0.9新版本使用问题汇集

帖子binjoo » 2013年 12月 18日 10:17

文档都木有权限的。。
头像
binjoo
 
帖子: 818
注册: 2009年 9月 11日 11:13
地址: 特兰联邦银河舰队驻太阳系地球办事处

Re: 0.9新版本使用问题汇集

帖子binjoo » 2013年 12月 19日 09:40

这文章要置顶啊。。。。
头像
binjoo
 
帖子: 818
注册: 2009年 9月 11日 11:13
地址: 特兰联邦银河舰队驻太阳系地球办事处

Re: 0.9新版本使用问题汇集

帖子joyqi » 2013年 12月 19日 10:01

binjoo 写道:文档都木有权限的。。


你应该已经有权限了吧
头像
joyqi
 
帖子: 419
注册: 2007年 7月 24日 19:43

Re: 0.9新版本使用问题汇集

帖子binjoo » 2013年 12月 19日 10:09

joyqi 写道:
binjoo 写道:文档都木有权限的。。


你应该已经有权限了吧



嗯,我现在有了。。
头像
binjoo
 
帖子: 818
注册: 2009年 9月 11日 11:13
地址: 特兰联邦银河舰队驻太阳系地球办事处

Re: 0.9新版本使用问题汇集

帖子godsina » 2013年 12月 19日 10:28

很好,很强大。。。
头像
godsina
 
帖子: 53
注册: 2010年 10月 13日 06:01

Re: 0.9新版本使用问题汇集

帖子reed » 2013年 12月 20日 08:38

好文章,顶了!
reed
 
帖子: 54
注册: 2012年 8月 27日 15:23

下一页

回到 使用问题

在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客
cron