typecho1.1还能在PHP 5.3环境下用吗

解决您在不同平台环境下遇到的安装和升级问题

typecho1.1还能在PHP 5.3环境下用吗

帖子Sakura » 2018年 1月 17日 11:47

因个人原因无法用php5.4,typecho1.1还能在PHP 5.3环境下用么?
头像
Sakura
 
帖子: 11
注册: 2017年 3月 3日 04:14

Re: typecho1.1还能在PHP 5.3环境下用吗

帖子ClayMore » 2018年 1月 18日 17:24

安装环境要求

PHP 5.4 以上
MySQL, PostgreSQL, SQLite 任意一种数据库支持,并在 PHP 中安装了相关扩展
CURL 扩展支持
mbstring 或 iconv 扩展支持
头像
ClayMore
 
帖子: 1834
注册: 2007年 11月 29日 02:55

Re: typecho1.1还能在PHP 5.3环境下用吗

帖子Sakura » 2018年 1月 18日 18:15

ClayMore 写道:安装环境要求

PHP 5.4 以上
MySQL, PostgreSQL, SQLite 任意一种数据库支持,并在 PHP 中安装了相关扩展
CURL 扩展支持
mbstring 或 iconv 扩展支持


那就是无解了咯。。。
头像
Sakura
 
帖子: 11
注册: 2017年 3月 3日 04:14

Re: typecho1.1还能在PHP 5.3环境下用吗

帖子leoysk » 2018年 1月 28日 11:53

typecho1.1可以在PHP 5.3环境下用,参考https://ysk.fun/typecho-php54/
leoysk
 
帖子: 2
注册: 2013年 3月 9日 16:08

Re: typecho1.1还能在PHP 5.3环境下用吗

帖子wasknk » 2018年 3月 8日 12:29

实测目前的稳定版(1.1-17.10.30-release)不行,报错了
PHP Parse error: syntax error, unexpected '[', expecting ')' in /var/www/html/install.php on line 242
wasknk
 
帖子: 1
注册: 2018年 3月 8日 12:21

Re: typecho1.1还能在PHP 5.3环境下用吗

帖子aaa789 » 2018年 3月 13日 14:36

66666666
aaa789
 
帖子: 1
注册: 2018年 3月 13日 14:33


回到 安装和升级问题

在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客
cron